1
Vote

Import hangs

description

First of all, thanks for the great tool! I appreciate your work and effort invested!

Unfortunatelly the CommandLine Helper hangs while importing a solution at 0.0%.
When I manually import the solution into the organization in the web application, it works fine.

We have different organizations on the CRM server. It fails only with one organization.
The solution is an unmanaged solution.

Any ideas?

file attachments

comments

AymericM78 wrote Oct 14, 2014 at 5:38 PM

Hi Oliver,

Thanks for your feedback!
I'm pleased to know that tool provides help as expected.

May I suggest you the following investigation ways :
  1. Can you try to import the solution with "Solution Import Tool" provided by the XrmToolBox https://xrmtoolbox.codeplex.com/ ?
  2. Can you have a look to the trace log from server side ?
    Maybe there is an explicit error message.
This will help to identify what's happen.

Thanks

OliverGraf wrote Feb 4, 2015 at 11:53 AM

Did you get any answers from the developer meanwhile regarding this issue?

AymericM78 wrote Feb 4, 2015 at 7:10 PM

Nope

JMascoe wrote Feb 11, 2015 at 3:11 PM

I was getting this same issue. It turns out the error was coming from an import job that never finished. I discovered this by running the below query against the offending CRM database.

SELECT SolutionName, Progress, StartedOn, CompletedOn
FROM ImportJob(nolock)
WHERE CompletedOn is NULL
ORDER BY StartedOn DESC

Since the job was not able to finish, the CompletedOn column contained a row that was stuck at NULL indefinitely. This was a problem because the CheckForExistingImportJob() method checks the ImportJob table for any NULL values in the CompletedOn column when it is checking for any running import jobs.

Basically the import was hung because it was waiting for a job to finish that never would.

I resolved this by adding a condition to CheckForExistingImportJob() to only look for unfinished import jobs that were created today. I don't know if this is the best solution for you, but it is what worked for me.

I hope this helps!

OliverGraf wrote Feb 16, 2015 at 2:01 PM

Thanks JMascoe,

that helped me!
An old solution import job was hanging (since 2012 :-))